Translate

Search This Blog

ORA-00314: log 3274 of thread 1, expected sequence# 3276 doesn't match 3276


I had power failure while there was heavy DMLs running on my database and after
restating machine I my database(running in noarchive log mode) did not start due 
failed automatic instance recovery due error:  "ORA-00314: log %s of thread %s, 
expected sequence# %s doesn't match %s". 
 
Strange part was lower log sequence number mentioned in error message was already 
applied fully to database and it was even not appearing in v$log as inactive,it was 
so old though there was another log group active so it means recovery was vital
 
So,I tried to recover using first broader recovery command preferred to start with as safe practice "recover
database" but it did not succeed then I tried same using RMAN and then using backup 
control file syntax. Recovery prompted for couple of log sequences which I supplied 
after joing and v$ and v$logfile for corresponding thread# and sequence# but recovery 
terminated saying "datafile 1 may need recovery" It just mean I was unlucky as in most
of cases this error is solved by recover database until cancel using backup controlfile
. Then I tried with recreating controlfile and then recovery and then I tried with 
clearing logfiles but it also did not give me any luck. Finally I had to restore from
cold backup. Luckily it was just a test database. 

 
 
oerr reasons: 
 
ORA-00314: log %s of thread %s, expected sequence# %s doesn't match %s
 *Cause:  The online log is corrupted or is an old version.
 *Action: Find and install correct version of log or reset logs.

Follow by Email